Back to overview
Maintenance

Update Navidrome

Apr 13, 2026 at 6:13am UTC  –  Apr 13, 2026 at 6:20am UTC
Affected services
Navidrome

Resolved
Apr 13, 2026 at 6:13am UTC

v0.61.2